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EngineerOffice 2017 Release/Change Log 
 

 

 

VERSION 17.0.21.4:  
   

Release Date: August 3, 2017  

 

 

1. Invoicing 

When creating a draft invoice using the Show Detailed Draft option, No Charge items would still show 

their full value in the Slip Details area. 

Resolution: Fixed. No Charge items will now display NO CHARGE in the Slip Details area and add $0 to the 

total, as intended. 

2. Billing > Outstanding screen 

Selecting multiple invoices and using the Email Selected option would result in the email window 

appearing with no attachments and no subject line. 

 

Resolution: Fixed 

 

3. Billing > Drafts screen 

When printing a selection of invoices, the SLIP DETAILS section of the invoice, that appears when you 

turn on the Show Detailed Draft option in Project > Billing > Options > Invoice Extras screen, is omitted 

anytime the window shows more than one invoice at a time. 

 

Resolution: Fixed 

 

4. Contacts > List screen 

The AMOUNT OWED field on this list screen was not protected by any kind of security permission. Also 

entire Contact list, Context report and Export option didn’t had any security restriction. 

 

Resolution: Fixed. Denying users the Billing & Payments > Access Billing security permission will now 

cause this amount to disappear from the display on the Contact list screen. Also Show (Others) security   

under Contacts will restrict the list, Context Report and Export option to show only those contacts 

who are created by logged in user. 

 

5. Contacts > Details screen 

In certain scenarios a Server Error was observed immediately after creation of a new database. 

 

Resolution: Fixed 
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6. Preferences > Users > HR 

In certain scenarios the HR details for an employee would be erased if their rates were changed. 

 

Resolution: Fixed 

 

7. Preferences > Users > Security screen > Time & Expense 

The Mark Time/Expense(s) as Non Reimbursable security option ALSO granted/denied permission to 

change the Charge Status of a Time/Expense entry. 

 

Resolution: Fixed 

 

8. Project > Details > Project Team screen 

There was a minor graphical anomaly on the list of employees that would partially cut off the last user on 

the list. 

 

Resolution: Fixed 

 

9. Projects > “Create New Project” popup 

The list of available project templates was not listed in alphabetical order as intended. 

 

Resolution: Fixed 

 

10. Project > Tasks screen 

There was a disparity in the BUDGET USED column, when phases with sub phases existed. 

 

Resolution: Fixed. Budget Used will now always properly reflect the Actual $ compared to the budget $, in 

all instances. 

 

11. Project > Tasks screen 

In some instances, ACTUAL HRS would be calculated incorrectly when using tasks with sub tasks. 

 

Resolution: Fixed. 

 

12. Project > Billing > Budget screen 

Deleting a sub-phase of a project would result in the Fee value of the parent phase not updating on the 

budgets screen. 

 

Resolution: Fixed. 

 

13. Reports > Employee Performance Report 

This report did not include Terminated employees even if they had valid time within the date range being 

reported on.  

 

Resolution: Fixed. 
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14. Reports > Payroll Report 

Various issues with this report were observed, depending on the nature of the search criteria used to run 

the report. 

 

Resolution: Fixed 

 

15. Reports > Time Reports 

If users are denied the security permission to be able to see other user’s times, they were still able to run 

time based reports and circumvent this security restriction. 

 

Resolution: Fixed. Time Based Reports will no longer provide other users time entries, even if searched 

on, if current user does not have this level of security.  

 

16. Reports > Time Card Bi-Weekly Report 

This report was automatically filtering out time entries on HOLD, whether asked to or not. 

 

Resolution: This built-in filtering has been removed. The report will now honor the search settings in this 

regard. 

 

17. Reports > Work In Hand Report 

The $Billed column was incorrectly counting ALL billed values. This resulted in the $Remaining, Unused 

Budget, and % Budget Remaining columns being inaccurate. 

 

Resolution: Fixed. This column should only count billed Basic Services. 

 

18. Reports > Time reports 

Time reports should show both the description and the task in the Description column, if a time entry 

has both. 

 

Resolution: Fixed. 

 

19. Time / Expense > List screen > ACTION: PRINT 

In certain scenarios the Time Expense List Report would throw an unhandled Server Error. 

 

Resolution: Fixed. 

 

20. Time / Expense > List screen -> Time/Expense Details screen 

In certain scenarios the PREV/NEXT Links did not work. 

 

Resolution: Fixed 
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VERSION 17.0.15.1:  
   

Release Date: April 03, 2017  

 
1. Reports/Security: 

Ability to set Report Security permissions for custom reports, just as you can for the standard reports. 

It should be fully possible to decide who does and does not have access to Custom Reports. 

 

Resolution: Feature Implemented  

 

2. Time/Expense > Time screen:   

This value should be exactly the same value as is shown in the % column in the ACTUAL section of the 

Project Billing Summary screen. Also the % should be updated to not show decimal places.  

 Resolution: Fixed  

 

3. Contacts>Notes:   

After creating a Note, go to its detail view and change the time simply to PM and save. Here we see the 

time appears in 24 Hour format but when we again go to detail view it appears in 12 Hour format.  

Resolution: Fixed  

4. Calendar>Filter: 

Search an Event by giving Project no. here we see Project name is fetched and vice versa, now change the 

screen and come back. The Project name disappears from the dropdown. 

 

Resolution: Fixed  

 

5. Contacts: 

Make a new database, the color of Admin contact appears white but we see the billing checkbox is 

already checked by default. 

 

Resolution: Fixed  

 

Preferences: 

Assign Project>Select by status>Cancel>Assign Projects> Here the radio button is on the specific Project 

but the heading reflects through status. 

 

Resolution: Fixed  

 

 

6. Project > Details > Phases/Codes: 

It was impossible to delete Phase from any Project. All Phases just say that they can't be deleted 

because they are in use, even when they are clearly not. 
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Resolution: Fixed 

 

7. Invoice: 

Invoices can’t be created or previewed. It happens if the Project Number has a space in it, OR the 

invoice number has a space in it. The problem happens when viewing drafts or finalized invoices, and is 

preventing customers from being able to invoice, or to view old invoices after upgrading, if either meets 

the above criteria.  

Resolution: Fixed 

 

8. Time/Expense > List screen>Print: 

Action>Print option always results in a blank report. Unless you arrive at the List screen by going through 

Time/Expense > Filter, first, then it works. 

This is wrong. It shouldn't matter how you get to the list screen. 

 

Resolution: Fixed 

 

9. RFI: 

Preferences > Project > Defaults > RFI Status screen - Add some custom statuses to the list. 

 

In Project > Logs > RFI - It is impossible to actually save an RFI with one of the previously added statuses. 

Even if you pick one from the dropdown, when making a new RFI, it just ignores your selection and 

instead saves the RFI with status CLOSED. 

 
 Resolution: Fixed 

10. AO<>QB Sync: 

If you send projects to QuickBooks, it will try to send ALL Phases. This causes a problem if a parent phase 

is NOT Active but the sub phase IS active, which then errors out. 

The sync tool needs to be intelligent to this situation and not try to sync a sub phase if any level of parent 

phase above it is not currently active. 

Resolution: Fixed 

 

11. Time Expense>Time Card>Print: 

Report optimized for performance. Users had reported that this report is slow when run on huge 

databases. 

 

Resolution: Fixed 
 

VERSION 17.0.12.5:  
   
Release Date: February 03, 2017  

 
1. Attach Expense Receipts with Invoices: (E) 
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We know users like to attach files to expense entries. Sometimes these are photos of receipts they have 
in hand while using the EngineerOffice Mobile app during travel. Other times, they want to attach scanned 
images of consultant invoices. Whatever the need, you now have the option to attach a copy of the image 
when creating an invoice. File types include GIF, JPEG or PNG. 

 
2. Create Time Entries from Calendar Events or To-Do Items (B, P, E) 

From the Calendar module, you can always take an event or a To-Do item and turn it into a time entry. 
Previously, all you had to designate was the Phase and Job Code. Now in EngineerOffice 2017, you can 
also add a Description to the record. If the project uses tasks for time entry, you can even associate one of 
the pending tasks to the time record. 

 
3. Track Probability for RFP Projects (P, E) 

Many firms create RFP (Request for Proposal) projects and need a way to monitor the probability of 
winning those projects for their revenue and staff planning. In EngineerOffice 2017, we’ve added the 
Probability Percentage field to the projects that are set as RFP. Using custom reports, you can also exploit 
this feature by projecting future revenue based on the value and probability of RFP projects. 

 
4. Enhanced Color Cues for Client Payment Status (B, P, E) 

In the Contact List screen, there are colored boxes to the left of the client names that indicate the status of 
their receivables. This year we’ve modified the colors: red means the client has a past due invoice; yellow 
means the client owes you money but the invoices are not past due; green means the client is paid in full 
or does not owe you any money.  
 
We have added Amount Owed column to the list, it will now show you the amount of money the client 
owes your firm. Furthermore, you can see this color status in the Billing check box when you open the 
detail of any client. 

 
5. Link Scanned Checks to Transactions (P, E) 

In EngineerOffice 2017, you can now attach files to a payment transaction. If you like to scan your client’s 
checks before depositing them, this new feature allows you to store the scanned images with the actual 
transactions.  

 
6. Enhanced Search Options for Time and Expense Records (B, P, E) 

We’ve added more fields to the Search screen, allowing you to find the information you need faster. For 
example, you can now search for records based on the total value of the time or expense entry. You can 
also search based on the bill or cost rates. 

 
7. Link Web Pages to Projects (B, P, E) 

Many firms create web pages for their projects or want to link a project to a client’s website. In 
EngineerOffice 2017, you can add a website URL for a project in the Projects > Details screen. 

 

 

 
8. Show Retainer Payments on Invoices without Showing Project Balance (B, P, E) 

You now have the ability to display any retainer payments made while also showing your clients the 
current invoice balance. Previously, if you wanted to display retainer payments, the invoice would 
automatically display the Project Balance. This new feature gives you greater flexibility as to what 
information you want to show or hide on your invoices. 

 
9. Smart and Intuitive Cost Rate System (B, P, E) 

One of the fundamental benefits of using EngineerOffice is its ability to track your employee costs 
separately from the billable value of their time and show you the profitability. However, this required your 
firm to calculate the cost for each employee outside of EngineerOffice and then enter that value in 
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Preferences > Users > Time and Expense. If an employee was given a raise, you had to recalculate their 
cost rate.  

 
In EngineerOffice 2017, you can enter your staff’s salary rate (say, $20/hr), Cost Rate Multiplier (say, 
2.85), and then EngineerOffice calculates their Effective Cost Rate. Whenever you modify their salary, 
their Effective Cost Rate gets updated automatically. This also explains what your multiplier is and if you 
need to, you can easily vary it per employee. If you don’t want to use the standard Cost Multiplier method, 
you can continue to manually enter your own Effective Cost Rate for each employee.  

 
10. Warning Notification when Changing Project Status (B, P, E) 

If you decide to change the status of an active project, EngineerOffice 2017 warns you if there are any 
existing time or expense records that have not been invoiced. This means firms are notified about unbilled 
records and do not risk losing that potential revenue before closing a project. 

 
11. Easily Update Active Projects with Default Job Codes (B, P, E) 

If your firm updates the Preferences > Projects with new Job Codes, you can now easily add the new 
codes to all active projects. This way you don’t have to manually add them to each project one-by-one. 

 
12. Smarter Dashboard Widgets (B, P, E) 

We’ve enhanced some dashboard widgets so they include totals when appropriate. For example, the 
Invoicing Chart displays the total invoiced values for the specified date range. The Payments widget 
includes totals for payments, retainers as well as a grand total. 

 

13. Earned Value Dashboard Chart and Report (P, E) 
One of the greatest indicators of success of your projects is knowing its Earned Value. In EngineerOffice 
2017, we’ve made it easy for you to understand the earned value of your projects. Dashboard have an 
Earned Value chart and we’ve also included a new Earned Value report, which not only shows you the 
earned value for each project and phase, but also tells you the value of the unbilled revenue. 

 
14. Earned Value Analysis (P, E) 

We are enhancing the Project Tasks screen to allow you to see, side-by-side, the percentage progress of 
your tasks compared to the percentage of the fee or budget that has been invoiced. This way, you can 
quickly understand if your invoiced values are lagging behind your earned value or not. 

 
15. Relative Date Ranges for Billing Analysis (B, P, E) 

We’ve enhanced the Billing module filters to allow you to set date ranges by relative dates rather than 
manually selecting the start and end dates. For example, you can now set the screen to display records 
for this month, this quarter, this year or past 12 months. 

 

 
 
 
 
 
Additional New Features (B, P, E) 

 
16. When searching projects, we’ve added an “Active” check box next to the Phase field so that users can 
restrict the search to those phases which are in use by active projects only. 
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17. We’ve added a feature that checks to make sure the version of QuickBooks your firm is attempting to 
sync with is one that we support. If your version of QuickBooks is not supported, a notification will appear on 
screen and the sync will not be attempted. 
 
18. You have the ability to create up to 6 tabs for each Contact address record. If the name of the tab is 
very long, simply hover over the tab and the full name is provided as a tooltip. 
 
19. You can now sort Project > General > Milestones by clicking on the column headers of Date, Event 
Name and Status. Previously, they were ordered by date only. 
 
20. We’ve added another option to the Time/Expense Update feature that allows you to update the Date 
field of the selected records. 
 
21. To reduce confusion, we’ve modified some of the items in the Project Status drop-down. “Open” is 
changed to “RFP-Open”, “Awarded” is changed to “RFP-Awarded” and “Awarded to Competitor” is changed to 
“RFP-Lost”. 
 
22. When memorizing reports, if you used a relative date (such as “This Quarter”), the memorized report 
now remembers to update to the current quarter. Previously, it remembered the specific quarter used when 
the report was memorized. 
 
23. We fixed a bug when creating draft invoices. The Invoice Cutoff Date screen, which opens prior to 
creating the draft, no longer accepts incorrect dates. You are warned if the date entered is incorrect. 
 
24. Many firms have renamed the label for the Project Department field. We have updated EngineerOffice 
2017 so that when you run a project search, the custom name given to the Department field is correctly 
labeled. 
 
25. We’ve fixed the data migrator so that the firms moving from EngineerOffice 2016 to 2017 better handle 
situations where a firm has no users with all privileges turned on. 
 
26. We have improved the warning message displayed when you attempt to create an invoice whose 
project has entries on hold, unapproved or incomplete. Previously the message was confusing to some users. 
 
27. In the Projects module, there is an “Active Only” check box to the right of the Search box. 
EngineerOffice 2017 now remembers the state of this check box, making it easier for users to leave it 
unchecked if they want. 
 
28. We’ve improved the Project Contact Directory report to allow you to sort the report by Client, Project 
Name and Project Number. In addition, within each section you can sort the contacts by First Name or Last 
Name. 
 
29. We’ve improved the Calendar module so that if you have set the filters on the left side of the Calendar 
View screen, those settings are retained when you log in next time. 
 
30. We’ve added the ability to duplicate a Calendar event whilst in the detail view. 
 
31. We’ve added the ability for you to use military time rather than entering time with am/pm. For example, 
you can enter “13:30” or “1:30pm” in EngineerOffice 2017. 
 
32. If a draft invoice exists for a project, you can now view the draft from any of the Projects > Billing 
screens, not just from the Projects > Billing > Options screen. 
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33. We’ve added a single-click method for you to clear out any filters that are used in the Time-Expense > 
Filter screen. 
 
34. We’ve added the ability to sort the Project Performance reports. 
 
35. We’ve added a new Transactions Summary report which includes the Project #, Project Name, Invoice 
#, Invoice Date, Invoice Amount, Date Paid, Amount Paid and Amount Remaining columns. 
 
36. In the Projects > Time/Expense screen, we’ve made the filters smarter. If your project does not require 
approval for time and expense records, these options do not appear in the Status filter list. 
 
37. We have added a new Export feature for Contacts. You can now take a list of contacts or a single 
contact, and export the standard contact information to a CSV file. 
 
38. We have enhanced the EngineerOffice Mobile app to allow you to display projects by name or 
number. Previously, they only displayed by name. 
 
39. We’ve improved the ability for EngineerOffice to accept all email domains in the Preferences > System 
> Email Settings screen. 
 
40. In Preferences > Users > Details, the Assign Project screen that pops up when you want to add users 
to a new project now includes the ability to assign users based on the project status and not just the project 
type. 
 
41. We’ve improved the Project dashboard widget to allow you to filter it as is typical with other widgets. 
 
42. We’ve improved your ability to search for transactions. You can now search on the Notes and 
Reference Number fields. 
 
43. We’ve improved the draft invoices when you select the “Show Detailed Draft” check box on the Invoice 
Extras tab. In EngineerOffice 2017, the detailed information is grouped by phase with sub-totals displayed for 
each group. This makes it much easier for reviewers to compare the potential bill value to amount being 
billed.  
 
44. We’ve made it easier for users to see which Phases and Job Codes are active. If it isn’t active, it will 
be greyed out.  
 
45. You can now edit the date and time field for Project and Contact notes. 
 
46. You no longer have to worry about attaching files to expense records where file names are longer than 
50 characters. EngineerOffice now accepts all files that you attach to expense records regardless of the 
length of the file name. 
 
47. We have improved the Project List report. If it’s sorted by client, it displays the full name of the client 
as indicated in the Contact Name field and not just the concatenated first and last name. 
 
48. We’ve added a setting in Preferences to set No. of Decimal Places for Time and Expense reports. By 
Default No. of decimals is set to 2. 
  
49. We’ve added a brand new Avery L7160 report under Contacts>Labels category. This report is great 
advantage for UK users. This address label is 2½ inches x 1½ inches with a layout of 21 labels per sheet. 
 


