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EngineerOffice 2014 Change Log 

 
 

 
VERSION 128:  
  
GENERAL  

1. EngineerOffice – QuickBooks sync was not working due to certification issue. This was fixed. 
 
 

VERSION 125: 
 
GENERAL 

1. General performance improvement in various screens. 
 

2. Fixed an issue with times on various screens pulling the server’s time instead of the client machines time. 
 

 
BILLING 

1. Fixed an issue with the filters on the Billing > Projects screen that allowed projects to be selected that shouldn’t have been which 
resulted in $0 invoices being created. 
 

2. Fixed an issue which prevented the batch printing of invoices in certain circumstances. 
 
CALENDAR  

1. Fixed an issue with the resizing of events on the Calendar View screen. 
 

2. Fixed an issue with the handling of invalid multi-day events. 
 

3. Fixed an issue where assigning a contact to an event would cause an error in certain scenarios. 
 
CONTACTS 

1. The Retainer Balance displayed in the Contact > Transactions tab of a billing client displays wrong if retainer refund transactions 
exist. 

 
PREFERENCES 

1. Fixed an issue in some environments where Inline reports could not be used because the hardcoded Viewer Format was not 
usable by some. Added a global preference checkbox in Preference > System > Print Setup > Print Inline Reports as PDF's.  
 

2. Fixed an issue which effected the Maintain State option within the project module. 
 

3. Fixed an issue which made it impossible to add custom report templates. 
 

4. Fixed an issue where the “View Invoices” security bit was not honored in the Billing > History screen. 
 
PROJECTS 

1. Fixed an issue where Invoice Expense Grouping would be wrong in certain cases. 
 

2. Fixed a rare display issue on the Project > Billing > Invoice screen which caused invoices to be impossible to view. 
 

3. Fixed an issue where markup was still being applied to Non-Reimbursable expenses, erroneously inflating the invoice value. 
 

4. Fixed an issue on the Project > Billing > Budget screen, which allowed it to be possible to delete job codes even if they were in use. 
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5. Fixed an issue when including the Fee Summary with an invoice; it would always show $’s regardless of the country settings in 
Preferences. 
 

6. Fixed an issue on the Project > General > Data screen which made it impossible to delete certain fields. 
 

7. Fixed an issue where the Fee column on the Budgets screen would zero out when saving in certain circumstances. 
 

8. Fixed an issue where the hours counts for employees on the Slips screen would count incomplete slips in this number. 
 

9. Fixed an issue where certain invoice grouping options were not implemented correctly. 
 

10. Fixed an issue where the “Create To Do” link displayed incorrectly in certain scenarios. 
 
REPORTS 

1. Fixed an issue where memorized A/R reports would cause the "Show Outstanding Only" checkbox to disappear. 
 

2. Fixed an issue where the Contact List Report would appear unsorted. 
 

3. Fixed an issue where the 5160 Label Report did not have the "Address to Use" option 
 

4. Fixed an issue in the Profitability Accrued Report where the $Invoiced column was wrong in some cases 
 

5. Fixed an issue in the Budget vs Actual Report where the EXPORT Format would misalign the Header fields 
 

6. Fixed an issue where the Work In Hand Report would not reflect the time amount for all the phases. 
 

7. Fixed a minor display issue on the Time Card Profitability Report which caused slips with a rate of $0 to display nothing instead of 
properly displaying the $0 rate. 
 

8. Fixed a display issue in the Profitability Accrued Report when handling sub phases. 
 

9. Fixed an issue which caused private memorized reports to be visible by anyone. 
 

10. Fixed an issue which caused the Budget VS Invoiced Report to report the $Inv column incorrectly on parent phases in certain 
instances. 
 

11. Fixed an issue in the Project Performance Cash Report where Payments were reported wrong in certain instances. 
 

12. Fixed an issue in the Invoice List Report where dates did not honor the International Date setting option. 
 

13. Fixed an issue in the Transaction List Report where retainer payments were not handled properly. 
 
TIME / EXPENSE 

1. Fixed an issue which made it impossible to ever use the Delete option on the List screen. 
 

2. Fixed a rare issue where the timer would turn on when saving a time entry. 
 

3. Fixed an issue on the Time and Expense tabs where the textual date did not honor the International Date setting option. 
 

4. Fixed an issue on the List screen which caused the UPDATE > Job Code and UPDATE > Both options to not work. 
 

 
VERSION 109 (Service Pack 1): 
 
 
DEVICE APP SUPPORTED – New Enhancement 
1. This update will install API components that enables EngineerOffice iPhone and Android app to connect to your company 
file and record time and expenses from the apps. 
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Note: You can download the EngineerOffice Device App from their respective App Stores by searching for EngineerOffice.  
 
BILLING 
1. In Billing > Drafts screen, added new option to Action menu to “Finalize and Print” 
 
2. In Billing > Drafts AND Billing > History screens, fixed an issue that caused Print Preview windows to be incomplete in 
some situations. 
 
3. Invoices based on custom invoice templates were not printable. 
 
CALENDAR 
1. Fixed issue with Yearly First “Weekday of Month” recurrence settings not recurring correctly. 
 
2. Fixed an alignment issue in the Calendar View screen, with the names and checkboxes in the Users filter becoming 
misaligned after clicking “Apply”. 
 
3. Fixed display issue with the Ampersand “&” character not being handled properly in certain places. 
 
4. Fixed issue with the handling of events when using international date format. In some instances, events with reversible 
dates would get displaced to the U.S. date. 
 
5. Fixed a rare issue where an event with year/monthly recurrences would all recur on the same month once sync’d to 
Outlook. 
 
6. Fixed an issue in the Calendar View screen that could rarely cause you date settings to be changed from International 
date format back to U.S. format. 
 
7. Fixed an issue where certain events would not be viewable in the Calendar View screen as they should be. 
 
8. Fixed an issue where events would not display on Saturday in the Calendar View screen. 
 
9. Fixed an issue with the display of multi-day events. Multi-day events were never intended to be possible in the first place 
and were only able to be created via an exploit to the Calendar View screen. This has been corrected. 
 
10. Fixed an issue where a crash was observed if setting an event to recur yearly, every month. 
 
11. Fixed an issue where it was possible to set a start and end time for an event AND mark it an All Day event. 
 
12. Fixed an issue where events which cross over midnight were not displayed properly in Calendar View screen. 
 
13. Fixed an issue where events would display incorrectly in the Calendar View grid if they were created in Details tab and 
certain events were never altered from new to save. 
 
14. Fixed an issue where changing event recurrence from Every Day to Every Weekday, would not be honored. 
 
15. Fixed an issue where setting the Recurrence to Yearly from Last Day of January would result in events starting on 
February 4th. 
 
16. Fixed an issue where creating a zero hour event length would not be displayed properly in the Calendar View screen. 
 
17. Fixed an issue where the settings in the Filter tab would influent FIND or REFIND actions in this module. 
 
18. Fixed an issue where the Calendar View filter lists would not display their items in alphabetical order. 
 
19. Fixed an issue where the Week view in the Calendar View screen would display the weeks date incorrectly after 
navigating if International date format was set. 
 
20. Fixed an issue where events were being shifted several hours when viewed on the Calendar View screen, based on how 
many hours away from the GMT time zone the user was located. 
 
21. Fixed an issue where All Day events were displayed on the previous day in the Calendar View screen. 
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22. Fixed an issue on the Calendar > Detail screen where event dates were always interpreted in U.S. format, causing those 
events to display improperly on the Calendar View screen. 
 
23. Fixed a display issue on the Calendar > Filter screen which would cause rows to disappear from the display if DATE or 
TIME column headers were clicked on to sort. 
 
CONTACTS 
1. A rare issue was fixed which would cause a crash if contact records were changed in a particular way. 
 
2. Fixed an issue which allowed the removal of the Billing checkbox from a contact which is currently assigned as the billing 
client on a project. 
 
3. Fixed an issue in the Company field where entering an ampersand (&) character would cause a lock up. 
 
4. Fixed a rare issue which would cause the address tabs to fail to retrieve information. 
 
5. Fixed a display issue which would cause a project to disappear from the contacts projects tab after sorting attempts. 
 
6. Fixed a rare issue that would cause multiple events to be created with only one new event creation attempt. 
 
7. Fixed an issue that would occasionally cause the List to now display. 
 
8. Fixed a display issue which would cause the modules banner to disappear in rare instances. 
 
DASHBOARD 
1. Fixed an issue that would cause an error if going to a particular Help screen from the dashboard. 
 
GENERAL 
1. A rare issue was fixed where two wrapper bars would occasionally appear immediately after a logout by timeout happens. 
 
2. Various minor issues with the help file were corrected. 
 
PREFERENCES  
1. Fixed issue causing “Remit By” invoice label setting to not be honored. 
 
2. Security flags to restrict ability to Edit Invoice and View Invoice were not honored. 
 
3. Security flags to restrict ability to work with Project Tasks were not honored. 
 
4. Fixed an issue where the Invoice Number settings could not be change in the Basic Edition. 
 
5. Fixed an issue where custom reports could not be added to the system. 
 
6. Fixed an issue when using Firefox that would cause an erroneous prompt to appear in Preferences > Users screens. 
 
7. Fixed a display issue in Preferences > Users > Other Options screen. 
 
8. Fixed an issue where the new company database would still use the old non-colored report/invoice sample logos. 
 
9. Fixed a rare issue where a 404 error would occur in Report Logos screen. 
 
10. Fixed an issue where changing the privilege category of users via owner would result in users name being displayed as 
owners ID, upon user login. 
 
PROJECTS 
1. A rare issue was fixed which caused a crash to occur during invoicing. 
 
2. Fixed a display issue in budgets screen which would occur if add. svcs. fees were changed back to 0. 
 
3. Fixed an issue where creating a submittal also automatically created a calendar event. 
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4. Fixed a display issue which would cause the modules banner to disappear in rare instances. 
 
5. Fixed an issue in Invoice Details screen that would cause the Invoice Date and Remit dates to swap from International to 
U.S. date format upon saving. 
 
6. Fixed an issue where the General > Performance screen was rounding values to the nearest dollar. 
 
7. Fixed an issue where the Billing > Summary screen was rounding values to the nearest dollar. 
 
8. Fixed a rare issue where the New Project dialog was not cleared upon creation of a new project. 
 
9. Fixed an issue where clicking the Active column on the Project Teams screen would result in the information icon 
displaying an incomplete message. 
 
10. Fixed an issue where creating a sub phase on a phase which already contains time slips would fail. 
 
11. Fixed an issue were certain billing options were not being hidden as they should be, when certain other option were 
chosen. 
 
12. Fixed an issue where the Slips tab would round displayed budgeted values to the nearest dollar. 
 
13. Fixed an issue which made it impossible to enter any value with cents in the budgets screen. 
 
14. Fixed an issue in Performance screen where “Total Cost To Date” field was counting the cost of incomplete slips. 
 
15. Fixed an issue where the Slips tab would round displayed employee values to the nearest dollar. 
 
16. Fixed an issue which made it impossible to set a negative percentage for expense markup. 
 
17. Fixed an issue where invoice phase order would display in alphabetical order instead of the order defined in the project. 
 
18. Fixed a minor alignment issue in the New Project dialog. 
 
19. Fixed a rare issue in General > Data screen where adding a picture would fail. 
 
20. Fixed a display issue in Billing > Options screen where certain tooltips would not display. 
 
21. Fixed a rare issue that caused an error when trying to change your project number. 
 
22. Fixed a minor alignment issue in the Performance screen. 
 
23. Fixed a display issue in Billing > Summary screen where certain tooltips would not display. 
 
QUICKBOOKS SYNC 
1. Fixed an issue which caused the SmartMatch > Automatch feature to fail in some cases. 
 
2. Fixed an issue which caused an unneeded prompt to appear whenever manually linking two records together. 
 
3. Fixed an issue when getting expenses from QB would result in the cost rate being set incorrectly in some situations. 
 
4. Fixed an issue where the GET > Expenses settings would not honor the user name selected to get expense to. 
 
REPORTS 
1. Fixed a minor display issue in the Document List Report. 
 
2. Fixed an issue in the Profitability Accrued Report where the $Invoiced column would sometimes calculate incorrectly. 
 
3. Fixed an issue in the Budget vs Actual Report where always include Additional Services. An option was added to allow 
this to be user selectable. 
 
4. Fixed an issue in the Budget vs Invoiced Report where the $Billed column would incorrectly include expenses. 
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5. Fixed an issue on the Time/Expense List Report where the job code column would actually display the job codes service 
type. 
 
6. Fixed an issue on the Budget Hours Report which caused phases to display out of order for some projects. 
 
7. Fixed an issue on the Profitability Accrued and Profitability Accrued with Expenses Reports where slips which were 
invoiced multiple times would display incorrect values. 
 
8. Partially fixed an issue which would cause search results screens to display when searching as part of a report. 
 
9. Fixed an issue where a custom report with an overly long description would cause the report to fail to run. 
 
10. Fixed an issue where deleting a custom report would not actually delete it. 
 
11. Removed Labels and Envelopes Reports in AO Online as these are only available in AO2014. 
 
12. Fixed an issue where the Work In Hand Report was displaying incorrect values. 
 
13. Fixed and issue where the Print Project Summary Report took a very long time to render. 
 
14. Remaining column added to the Print Project Summary Report. 
 
15. Fixed an issue on the Budget vs Invoiced Report were values from Hourly invoices were not being counted in the $Inv 
column. 
 
16. Fixed an issue in the Project Fee Summary Report was not ordered properly. 
 
17. Fixed an issue in the Time Card Half Monthly Report where any time currently in draft status was omitted. 
 
18. Fixed a minor display issue in the Accounts Receivable Report. 
 
19. Changed the sort order of the Project Slip Report to order by Project FIRST, THEN by employee, and expense type. 
 
20. Fixed an issue where certain Avery labels were not sorting correctly in some situations. 
 
SEARCH ENGINE 
1. Fixed an issue in the Project Search screen where the Extend / Reduce options were non-functional. 
 
TIME/EXPENSE 
1. Fixed problem where if changing the project of a time slip, using the update option, to a project that has setting "Slips 
Require Approval" checked, does not result in the slip being changed now asking for Approval. (Even if the slip was already 
approved and the target project has setting "Slips Require Approval" checked). 
 
2. Fixed a display problem when using Sub Job Codes which were added after initial project creation. 
 
3. Fixed an issue where charge status was incorrectly set to Charge when updating expense slips from Expense screen, 
when expenses were previously set to No Charge or Hold. 
 
4. Fixed a rare issue which would initially prevent the creation of new time or expense entries. 
 
5. Fixed an issue which would erroneously reset Client Reimb. setting when using employee reimbursable update settings 
from the List screen even if user was denied the privilege to edit this setting. 
 
6. Fixed an issue which would erroneously reset the Markup setting when using the update options from the List screen 
even if user was denied the privilege to edit this setting. 
7. Fixed a rare issue where No Charge slips were not displayed on the invoice unless the “Slips Require Approval” option 
was set on that particular project. 
 
8. Fixed an issue where the Client Reimb. and Markup flags could not be changed on No Charge slips. 
 
9. Fixed an issue where in the Time tab where deleting an entry caused the list to clear. 
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10. In Time/Exp List screen, changed “Reimb/Non-Reimb” labels to “Client Reimb/Client Non-Reimb”. 
 
11. Fixed an issue where slips could not be updated to/from No Charge status. 
 
12. Fixed an issue where duplicating approved slips would result in new slips which were also duplicated. 
 
13. Fixed a minor issue in Details tab which would cause the Hrs Used/Hrs Remaining boxes to be inaccurate. 
 
14. Fixed an issue which made it impossible to use Update options to change Emp Reimb/Paid Out flags. 
 
15. Fixed an issue in Details tab where the Save and New option would break the charge status dropdown. 
 
16. Fixed an issue where using the Update options to change the charge status on an incomplete slip would cause it to be 
marked complete. 
 
17. Fixed an issue where the status image of a slip would not change in certain scenarios. 

 
EngineerOffice Online 
 
Management Portal: 
1. Fixed a crash that would occur if we tried to create a new user under Manage Users tab, after deleting company data file. 
 
2. Fixed a crash that would occur after deleting a company file, creating a new one, and going to the Calendar module. 
 
3. Fixed an error that would happen after buying a license then deleting a licensed user. 
 
4. Fixed a "First and Last names are required" error that would happen when creating a new trial account. 
 
5. Previously entered credit card information was not displayed properly when later attempting to add additional licenses. 
 
6. Fixed an issue where deleting users resulted in a crash in some situations. 
 
7. Fixed an issue where clicking the “Try It Free” would cause it to then display a Signup button. 
 
8. Fixed a display issue that caused contacts to not display any data. 
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VERSION 67: 

 
TIME/EXPENSE 
1.  Fixed a problem where duplicating a Time or Expense record would also result in duplicating the invoiced amount and 

approved status. 
 

2.  Fixed the problem which would occur when changing the status of a billed time slip to unbilled and then modifying the 

total amount. Upon invoicing the record was not showing the new updated value. 
 
PROJECTS 

1.  Submittal numbers are now limited to 10 characters. 
 

2.  Fixed a problem where the Project Type field was displaying values from the Note Type field. Also searching the 

Project Type field was similarly incorrect. 
 

BILLING 

1.  You can now overwrite the default invoice number and enter a custom invoice number when creating an individual 

invoice from the Projects module. 
 
REPORTS 

1.  In Reports > Billing > Credit Memo Report - The Project Status option is now available. 
 

2.  The Time Card Half Monthly and Time Card Bi Weekly Reports now includes no-charge and incomplete records. 
 

3.  The Accounts Receivable Report now includes both the Project Name and Project Number regardless of which sort 

order is selected. 
 

CALENDAR 

1.  Fixed a problem where events were shifted on the calendar view. 
 
 

GENERAL 

1.  Handled TCP IP port in SQL connection string. 
 

2.  Unicode / special characters (such as æ, ø and å) are now working and available in dropdown menus and 

QuickSearch and normal search. 
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VERSION 61: Public Release 1 

Welcome to EngineerOffice 2014. 

  

If you are reading this log, you are most likely an existing EngineerOffice customer who is in the process of upgrading from  

EngineerOffice 2011, 2012 or 2013. 

 

If you have participated in our beta test program, thank you so much for all the wonderful feedback you provided. We’ve 

tried to incorporate all the findings of the beta test group and the few items that haven’t been incorporated we expect to 

see addressed in our first service pack. 

 

Each time we release an update you should also download and read the change log to familiarize yourself with new 

features, fixes and other changes 

 

Here is a list of 15 of the more than 30 new features you will find in EngineerOffice 2014 

 
1.  Itemized Invoices with Task and Description: If your projects allow you to create timecard records by selecting from 

a list of tasks you can now display both the task and any description that the employee may have added to the record 

in your itemized invoices. Previously, if Tasks were used, only the task would appear on the invoice. You can control 

this setting at the project level by going to Projects>Billing>Options>Invoice Format 

 

2.  Transfer Retainers between Projects: You can now move retainer balances between projects owned by the same 

client. 
 

3.  Start of Week Preference: No longer are you forced to start your timecard week with Sunday. In EngineerOffice 2014 

you can control which day of the week is the start day for your firm’s timecard and timecard reports. Change this 

setting in Preferences>System>Defaults. 
 

4.  Billing Summary Screen Report: Based on numerous requests we have gotten from customers, we have added a 

menu item to the Action list on the Projects>Billing>Summary screen that will allow you to print a report displaying the 

information seen on screen.  
 

5.  Project Leader Reports: We have added the option to many popular Project reports to sort by Project Leader. This 

includes the Profitability reports as well as all the Budget vs … reports. 
 

6.  Date Range added to Profitability Reports: We have added the ability to select a date range when preparing 

Profitability Reports. No longer do you simply see the profitability on projects - but you can see it during various stages 

in the timeline. 
 

7.  Output Report Options Remembered: If you output your reports to PDF or other allowed formats, EngineerOffice 

2014 will remember which format you last used so the next time you create the report you don’t have to select the 

same option again. 
 

8.  Billing Reports by Project Status: We added a new Project Status selection menu to the Billing reports. This makes 

it easy for you to run these reports for only Active, Inactive or All projects without running a special Search. 
 

9.  Bill Statement Report Enhancement: We have now added a Retainer column to the Bill Statement making it easy for 

you to see all transactions (payments, credits and retainers) as well as the Remaining Balance for your client ’s 

invoices. 
 

10. Print Client Statement Reports from any project: There is a new option in the Projects>Billing>Invoices screen to 

Print Client Statement. This report will not only print out the outstanding invoices for the selected project, but will also 

show all other projects for that client that have outstanding invoices. 
 

11. Project Performance Reports: We have added two new reports: Project Performance Accrued and Project 

Performance Cash which will provide you with the valuable financial information found in the Projects > General > 

Performance screen. WARNING: this report is not fully functional. It will be updated in Service Pack 1. 
 

12. Draft Invoices with watermark: We have made it much harder for you to confuse a draft invoice from a finalized 

invoice with the addition of a “Draft” watermark on all draft invoices. 
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13. Invoice Dates and Date Ranges remembered: EngineerOffice will remember the values of the date fields when 

creating invoices. So if you are creating invoices for March 31st you don’t have to continually enter the date each time 

you create an invoice. Set it once and EngineerOffice will use that date for each subsequent invoice.  
 

14. No-charge time easy to identify: We’ve added a new red “N" icon to time records that have been marked No-charge 

making it easy for you to identify these on screen lists and reports. 


